… could it be my machine or my browser?

For the last couple of weeks, Facebook has loaded/operated like a snail with a stomach ache. The time from pointing my browser at it to the page being fully loaded (including whatever “dynamic content” it pulls up) has gone from a few seconds to more than half a minute on a good day.

It’s not my connection (other sites load fine and I’ve messed with e.g. DNS, switching from my usual Cloudflare 1.1.1.1 to Google servers and “automatic” to see if anything changes).

So far as I can tell, that leaves three possibilities.

One is my machine. I switched from an aging Chromebox to a newer Chromebook as my desktop machine a few weeks ago. But the Chromebook should be, and so far as I can tell is, faster than the old Chromebox, and the problems did not start at the same time as the switch.

Another is my browser. There have been at least a couple of recent ChromeOS updates. But if that’s the problem, it doesn’t seem to be affecting anything but Facebook. I haven’t added any new browser extensions recently either.

The final one is Facebook itself. I don’t watch the site closely enough to have noticed if they’pre adding a bunch of crap to it that might slow down site loading.

Anyone else having (recently discovered) problems with Facebook? Anyone else have a clue as to what’s causing them?

I’ve resisted giving up Facebook because I happen to like a lot of its features and since my privacy went in the shitter as soon as I joined the Google ecosystem anyway. But I’m at the point of giving up on it because it’s getting hard to use.

Imported from the original KN@PPSTER